<!doctype html>
<html lang="en">

 <head>
  <META http-equiv="Content-Type" content="text/html; charset=UTF-8" />
  <META NAME="author" content="Sanders County Ledger" />
  <META NAME="description" CONTENT="The Paradise Center is a place of education and history, but last weekend it was the site of thievery, bribery and even murder. Throw in a ghost and" />
  <META NAME="keywords" CONTENT="" />
  <META NAME="robots" CONTENT="index,follow" />
  <META HTTP-EQUIV="cache-control" CONTENT="private, no-store, no-cache, must-revalidate" />
  
  <META NAME="revisit-after" CONTENT="1 days" />
  
  <META PROPERTY="og:title" CONTENT="Imagination on display">
<META PROPERTY="og:description" CONTENT="The Paradise Center is a place of education and history, but last weekend it was the site of thievery, bribery and even murder. Throw in a ghost and the vivid imagination of a writer, and people had the chance to see the latest play of the Paradise Players. It’s been two years since the Paradise Players have had the chance to take to the stage an...">
<META PROPERTY="og:url" CONTENT="https://www.scledger.net/story/2021/10/14/communities/imagination-on-display/6899.html">
<META PROPERTY="og:site_name" CONTENT="Sanders County Ledger">
<META PROPERTY="og:type" CONTENT="website">
<META PROPERTY="og:image" CONTENT="https://www.scledger.net/home/cms_data/dfault/photos/stories/id/9/9/6899/s_top">
<META PROPERTY="og:image:type" CONTENT="image/JPEG" />
<META PROPERTY="og:image:width" CONTENT="1000" />
<META PROPERTY="og:image:height" CONTENT="505" />
  <title>Imagination on display - Sanders County Ledger</title>
  
      <meta name="viewport" content="width=device-width, initial-scale=1">
      <link rel="stylesheet" type="text/css" media="screen" href="/app/website_specifics/css_themes/white-3col/white-3col.css" />
      <link rel="stylesheet" type="text/css" media="screen" href="/app/website_specifics/pdf_click_menu_small.css" />

      <link rel="stylesheet" type="text/css" media="screen" href="/app/website_specifics/slick/slick.css" />      
      <link rel="stylesheet" type="text/css" media="screen" href="/app/website_specifics/slick/slick-theme.css" />
         <link rel="stylesheet" type="text/css" media="screen" href="/home/cms_data/dfault/configuration_files/css_customizations/white/white.css" />
         <link rel="stylesheet" type="text/css" media="print" href="/app/website_specifics/print.css" />

<!-- Desktop/canonical vs. mobile/alternate URLs -->
<link rel="alternate" media="only screen and (max-width: 640px)" href="https://www.scledger.net/story/2021/10/14/communities/imagination-on-display/6899.html?m=true">


<link rel="stylesheet" type="text/css" href="/app/website_specifics/fonts/font-awesome-4.6.1/css/font-awesome.min.css"/>
   <script src="/app/website_specifics/jquery-2-2-2.min.js"></script>
 <script src="/app/website_specifics/slick.js"></script>
   <script src="/app/website_specifics/lionslight.js"></script>

    <script>

     function offsiteLink(a,b){
      a.href='/ajax/selectit?storyId='+b;
      return false;
     }
     function offsiteAdLink(a,b){
      a.href='/ajax/adselectit?adid='+b;
      return false;
     }


     debug=false;


     function expiredAJAX() {
      // noop
     }


     function RemoveContent(d) {document.getElementById(d).style.display = "none";}
     function InsertContent(d) {document.getElementById(d).style.display = ""; swapdiv(d);}

     function swapdiv(a){
      if (a=='div2'){
       CLEAR.f.runOverlay('/ajax/popular/blogged');
      } else {
       CLEAR.f.runOverlay('/ajax/popular/viewed');
      }
     }

    
    </script>
  
  
  
<script>$(function() {
    var submitIcon = $('.searchbox-icon');
    var inputBox = $('.searchbox-input');
    var searchBox = $('.searchbox');
    var isOpen = false;
    submitIcon.click(function () {
        if (isOpen == false) {
            searchBox.addClass('searchbox-open');
            inputBox.focus();
            isOpen = true;
        } else {
            searchBox.removeClass('searchbox-open');
            inputBox.focusout();
            isOpen = false;
        }
    });
    submitIcon.mouseup(function () {
        return false;
    });
    searchBox.mouseup(function () {
        return false;
    });
    $(document).mouseup(function () {
        if (isOpen == true) {
            $('.searchbox-icon').css('display', 'block');
            submitIcon.click();
        }
    });


 runIf($('.menu').length,'jQuery.sticky','/app/website_specifics/sticky.js',function(){
  $(".menu").sticky({ topSpacing: 0, center:true, className:"stickynow" });
 });



});
function buttonUp() {
    var inputVal = $('.searchbox-input').val();
    inputVal = $.trim(inputVal).length;
    if (inputVal !== 0) {
        $('.searchbox-icon').css('display', 'none');
    } else {
        $('.searchbox-input').val('');
        $('.searchbox-icon').css('display', 'block');
    }
}












runIf=function(condition,name,url,callback){
 if(condition){
  runSafe(name,url,callback);
 }
}







runSafe=function(name,url,callback){
 if(typeof window[name] != 'undefined'){
  callback();
 } else {
  if(typeof runsafe != 'object'){runsafe={};}
  if(runsafe[url] && runsafe[url].constructor === Array){var loadit=false;} else {runsafe[url]=[];var loadit=true;}
  runsafe[url].push(callback);
  // START001 UI stuff not necessary
  // if (document.body){document.body.style.borderTop="10px solid red";}
  // END001 UI stuff not necessary
  if (loadit){
   var js = document.createElement('script');
   js.async = true;
   js.src = url;
   js.onload = js.onreadystatechange = (function(){return function(){
    while(runsafe[url].length){
     var f=runsafe[url].shift();
     f();
    }
    delete runsafe[url];
    var count = 0; for (var k in runsafe) if (runsafe.hasOwnProperty(k)) count++;
    if(count==0){
     // START002 UI stuff not necessary
     if (document.body){document.body.style.borderTop="none";}
     // END002 UI stuff not necessary
    }
   }})();
   var first = document.getElementsByTagName('script')[0];
   first.parentNode.insertBefore(js, first);
  }
 }
}










</script>

<style>
  
  .preLoadImg {
    display: none;
  }

#undefined-sticky-wrapper:before {
 height:50px;
 background-color: #B6BD98;
}


</style>

<!-- CSS for print_sub_alert -->
<style>

.print_sub_container {
    width:auto;
}
.print_sub_container div {
    width:auto;
}
.print_sub_container .print_sub_header {
    background-color:#c7edfc;
    padding: 12px 2px;
    cursor: pointer;
    font-weight: bold;
}
.print_sub_container .print_sub_content {
    display: none;
    padding : 5px;
}

</style>




 <script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js'></script></head>
 <body id="mobile_false">


<img class="preLoadImg" src="/home/cms_data/dfault/images/home-menu-icon.png" width="1" height="1" alt="" />
<img class="preLoadImg" src="/home/cms_data/dfault/images/home-menu-active-icon.png" width="1" height="1" alt="" />



<!-- BEGIN TEXT THAT APPEARED BEFORE THE MAIN DIV. -->

<!-- END TEXT THAT APPEARED BEFORE THE MAIN DIV. -->


  <div class="container container_3">
   <div class="outer_standard_links outer">
   <div class="standard_links inner widen_vertical_padding skel">
    <div class="standard_links_left">
     <p class="wide_spacing small align_left">
      <a  href="https://www.scledger.net/classifieds" >Classifieds</a><a  href="https://www.scledger.net/directory" >Directory</a><a  href="https://www.scledger.net/photos" >Photos</a><a  href="https://www.scledger.net/about" >About</a><a  href="https://www.scledger.net/contact" >Contact</a><a  href="https://www.scledger.net/advertise" >Advertise</a>
     </p>
    </div>
    <div class="standard_links_middle">
     <p class="wide_spacing small align_center">
      <a  href="https://www.facebook.com/sanderscountyledger"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/facebook.png'  height='21' alt=''></a><a  href="https://www.scledger.net/rss"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/rss.png'  height='21' alt=''></a>
     </p>
    </div>
    <div class="standard_links_right">
     <p class="wide_spacing small align_right">
      <a  href="https://www.scledger.net/trial" >Free Trial</a><a  href="https://www.scledger.net/subscribe" >Subscribe</a><a  href="https://www.scledger.net/login?r=%2Fstory%2F2021%2F10%2F14%2Fcommunities%2Fimagination%2Don%2Ddisplay%2F6899%2Ehtml" >Sign In</a>
     </p>
    </div>
   </div>
   </div>
   

   <!--/// Header ///-->
   <div class="outer_header widen_vertical_width outer">
   <div class="header widen_vertical_padding inner skel">
    <h1>Sanders County Ledger - Your Best Source For Sanders County News</h1>
    <a href="https://www.scledger.net/">
     <div class="header_story_full_logo">
 <!--<img src='/home/cms_data/dfault/images/masthead_1000x100.png' alt="">-->
     </div>
    </a>
 
   </div>
   </div>
 
   <div class="outer_search_bar outer">
   <div class="search_bar widen_vertical_padding inner skel">
    <div class="grid_2">
     <p class="small a2a_padding">
      
     </p>
    </div>
   </div>
   </div>
   <div class="outer_navigation outer">
    <div class="navigation inner skel">




<div class="menu widen_vertical_padding">
 <ul>
  <li class="home-menu-icon">
   <a class="" href="https://www.scledger.net/" data-tag="home"><span>Home</span></a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.scledger.net/section/news">News</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.scledger.net/section/sports">Sports</a>
  </li>
  <li class="menu_right_border">
   <a class="active" href="https://www.scledger.net/section/communities">Communities</a>
   <!--[if lte IE 7]><a href='#'>the_section<table><tr><td><![endif]-->
   <ul>
    <li>
     <a href="https://www.scledger.net/section/communities/crossword%5Fsolution">Crossword Solution</a>
    </li>
   </ul>
   <!--[if lte IE 7]></td></tr></table></a><![endif]-->
  </li>
  <li class="menu_right_border">
   <a href="https://www.scledger.net/section/opinion">Opinion</a>
   <!--[if lte IE 7]><a href='#'>the_section<table><tr><td><![endif]-->
   <ul>
    <li>
     <a href="https://www.scledger.net/section/opinion/editorial">Editorial</a>
    </li>
    <li>
     <a href="https://www.scledger.net/section/opinion/letters%5Fto%5Fthe%5Feditor">Letters to the Editor</a>
    </li>
   </ul>
   <!--[if lte IE 7]></td></tr></table></a><![endif]-->
  </li>
  <li class="menu_right_border">
   <a href="https://www.scledger.net/section/obituaries">Obituaries</a>
  </li>
  <li id="new-search-white">
   <form method="GET" class="searchbox" autocomplete="on" action="/findit" NAME="findit">
    <input class="searchbox-input" type="search" onkeyup="buttonUp();" placeholder="Search" name="mysearch" required="" value="">
    <input type="image" src="/app/images/search-img-icon-sm.png" name="mybutton" data-value="Search" class="searchbox-submit" alt="search">
    <span class="searchbox-icon"><img src="/app/images/search-img-icon-sm.png" class="searchbox-img" alt=""></span>
   </form>
  </li>
</ul>
 </div>
    </div>
    </div>
   <div class="outer_maincontent outer">
   <div class="maincontent widen_vertical_padding inner skel">
    <div class="maincontent skel">
     <div class="grid_2">
      <!--/// Begin Article from headline... ///--><!-- open the "right_border" div --><div class="right_border">	<div class='author'><a href='https://www.scledger.net/author/ed_moreth'></a><p>By <a href='https://www.scledger.net/author/ed_moreth'>Ed Moreth</a>&nbsp;		</p>
	</div><h2>Imagination on display</h2><p class="tagline">Paradise Players on stage for first time in two years</p><div class='clear'>&nbsp;</div><!--/// CLEAR ///--><div class="title_separator"></div><div class="volume_issue">
<div class="a2a_kit a2a_kit_size_20 a2a_default_style single-social">
    <a class="a2a_button_facebook bothsociallink_border"><img src="/cms/images/social_media_icons/buttons/facebook_15_white.png" alt="facebook">&nbsp;&nbsp;Share</a>
    <a class="a2a_button_twitter bothsociallink_border"><img src="/cms/images/social_media_icons/buttons/twitter_13_on_15_white.png" alt="twitter">&nbsp;&nbsp;Tweet</a>
    <a class="a2a_dd bothsociallink_border" href="https://www.addtoany.com/share" data-annotation="none"><img src="/cms/images/social_media_icons/buttons/addtoany_nobox_15_white.png" alt=""></a>
    <a class="comment_link_button bothsociallink_border" href="#readercomments" TAG="id-6899">0 Comments</a>

</div>
<script src="//static.addtoany.com/menu/page.js" async></script>
<p>October 14, 2021</p>

</div><div class="top_image_left"><a href='https://www.scledger.net/photos/big/6899/12'><img src="/home/cms_data/dfault/photos/stories/id/9/9/6899/.TEMP/s_topTEMP425x425-7685.jpeg" width="425" height="215" alt=""></a></div><div class="p402_premium"><P>The Paradise Center is a place of education and history, but last weekend it was the site of thievery, bribery and even murder. Throw in a ghost and the vivid imagination of a writer, and people had the chance to see the latest play of the Paradise Players.</p><p> It’s been two years since the Paradise Players have had the chance to take to the stage and the first time for Kathleen Hubka to direct the troupe with a rendition of “Seven Keys to Baldpate Inn.”</p><p> “They were pretty amazing. They were very refreshing,” said Hubka of her 11 cast members last weekend, which had performances on Friday, Saturday and Sunday and drew just over 120 people. This might have been the first time for Hubka’s direction of a local group, but she’s no stranger to directing. She spent 40 years in the theater in Nebraska, where she worked with high school and college students and directed hundreds of plays. </p><p> The play, written in 1913 by George M. Cohan, centers around Billy Magee (Michael Murray), who goes to the Baldpate Inn in the dead of winter, when the inn is closed, to write a 10,000-word novel as part of a bet, but he needs to be alone and without interruption. Inn caretaker Eliza Quimby (Mary Lou Hermes) and her sister, Martha Quimby (Rochelle Lukehart) tells Magee he has the only key, something he discovers is incorrect when others start showing up with their key, including Lou Caprionni (Benjamin Winkler) looking to retrieve a million dollars from the inn safe for the mayor (William Largent). The entourage of visitors continues with the mayor’s fiancé (Deborah Davis), a reporter (Sharon Murray), president of the railroad (Butch Murdock), his assistant, Max, (Hubka), and the police chief (Robert Reece). It becomes a myriad of antics and accusations concerning the missing money. The first person implicated was Nancy the Hermit (Myra Lindborg) who some believed was a ghost. Myra Thornhill, (Susannah Lindsay) shows up with the intention of stealing the money, but is killed by Caprionni and comes back as a ghost. Nancy the Hermit finally admits to burning the money. The railroad president shoots her, but soon there’s a shootout and they all die. The lights dim and when they come back on it’s revealed the whole episode was Magee’s novel.  </p><p> The majority of the cast has been with the Paradise Players for several years. Hermes and Hubka selected the play. Initially, Hermes was supposed to direct, as she had done with numerous plays before, but she switched with Hubka. Nora Verpoorten of Plains was supposed to play the hermit, but was injured a week before show time and her sister, Lindborg, who had made Verpoorten‘s costume, took on the role. </p><p> Seven Keys to Baldpate Inn saw three new actors — Reece and Lindsay of Plains and Largent of Thompson Falls. Lindsay, 16, was a stagehand in the 2019 play “Blazing Guns at Roaring Gulch,” although she and Largent did participate in a handful of plays put on by the Missoula Children’s Theater. “I loved it and want to do this again,” said Lindsay, who recruited Largent, also 16, to play the mayor. Largent is also a member of “Dance Xplosion” in Thompson Falls. “I love entertaining an audience. I like to change things up and play off the audience’s energy,” he said. </p><p> The 35-year-old Winkler has been acting since he was about five years old when his mother, the late Ruth Wrinkler, put on plays at Paradise School. Michael Murray has extensive acting experience with about 30 plays in California and has a master’s degree in drama. He has also directed two plays at the Paradise Center. This was the third play for Lukehart. Murdock has been in several Paradise plays and during intermission entertained the crowd by singing “Hello Walls” and “Ballad of the Mean Queen” acapella. </p><p> Hermes said she enjoys acting. She missed directing the play, but felt Hubka did a great job. “She’s a breath of fresh air for us because she has big ideas,” said Hermes. “I do enjoy directing plays,” said Hubka. “Every performance is different, because every audience is different. That’s why live theater is so special. The cast really gets energy from the audience,” she added. The Plains resident said she reads a lot of plays looking for something intriguing, keeping in mind the casting set design and technical aspects. She’s thinking about doing another play later this year and has an idea for the next play, which might be an all-girl cast. </p><p class="skel"></p><div class="bottom_image_right"><a href='https://www.scledger.net/photos/big/6899/13'><img src="/home/cms_data/dfault/photos/stories/id/9/9/6899/.TEMP/s_bottomTEMP425x425-8962.jpeg" width="425" height="344" alt=""></a></div><p> “This is a terrific group of people, such great personalities, with terrific work ethic and very generous attitudes. It’s hard to believe that there is a 70-year age gap between our oldest and youngest cast member. I’m very lucky to be involved with Paradise Players,” she added. “This show had tech aspects that we just couldn’t meet. I am unhappy about that, because it would have really enhanced the script. However, the story was good and the characters were a lot of fun, so I am very happy with our efforts.” </p><p> Money raised at the play will go to upgrade the light and sound system, which was run by Plains resident Doug Wilkes last weekend. Hubka also put out an appeal for more actors.</P></div><!-- close the "right_border" div --></div>
    <script> 
      try { _402_Show(); } catch(e) {} 
    </script><p class="skel"></p><div>
	<fieldset>
		<legend>You might be interested in:</legend><ul><li class='other_interest'><a href='https://www.scledger.net/story/2021/09/23/communities/farm-to-table-fresh/6792.html' >FARM-TO-TABLE FRESH</a></li><li class='other_interest'><a href='https://www.scledger.net/story/2021/09/16/communities/art-exhibit-brightens-cfvh-hall/6753.html' >Art exhibit brightens CFVH hall</a></li><li class='other_interest'><a href='https://www.scledger.net/story/2021/10/07/communities/tfhs-improvements-become-a-reality/6871.html' >TFHS improvements become a reality</a></li><li class='other_interest'><a href='https://www.scledger.net/story/2021/09/23/communities/cooper-leforce-wedding/6806.html' >Cooper-LeForce Wedding</a></li><li class='other_interest'><a href='https://www.scledger.net/story/2021/09/30/communities/living-artwork/6821.html' >LIVING ARTWORK</a></li></ul></fieldset></div><div class="clear">&nbsp;</div><!--/// CLEAR ///--><!--END CONTENT AREA-->
     </div>
     
     <!--BEGIN SIDEBAR CONTENT AREA-->
     <div class="sidebar_grid align_center"><!--BEGIN SIDEBAR CONTENT AREA--><div id="most_popular"><table style="width:100%;"><tr><th colspan="2">Most Popular</th></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.scledger.net/story/2021/10/14/opinion/our-viewpoint/6902.html'><img src='/home/cms_data/dfault/images/mostpopular_default_photo_67x50.jpg' width='67' height='50' alt=''></a></td><td class='mp_article' style='width:75%;'><a href='https://www.scledger.net/story/2021/10/14/opinion/our-viewpoint/6902.html'>Our Viewpoint<span class='mp_author'></span></a></td></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.scledger.net/story/2021/10/14/obituaries/john-david-chad-kavanaugh/6914.html'><img src="/IMG/b1r6-3-o2J1SxQ8Jwz1EL6ruE/XPATH/home/cms_data/dfault/photos/stories/id/1/4/6914/s_topXEXT1537x32838is.jpg" width="67" height="50" alt=""></a></td><td class='mp_article' style='width:75%;'><a href='https://www.scledger.net/story/2021/10/14/obituaries/john-david-chad-kavanaugh/6914.html'>John David 'Chad' Kava...<span class='mp_author'></span></a></td></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.scledger.net/story/2021/10/14/news/sanders-county-and-beyond/6919.html'><img src="/IMG/Zzrt1-8n38oOnW1F547FR749t/XPATH/home/cms_data/dfault/photos/stories/id/1/9/6919/s_topXEXT1557x32879is.jpg" width="67" height="50" alt=""></a></td><td class='mp_article' style='width:75%;'><a href='https://www.scledger.net/story/2021/10/14/news/sanders-county-and-beyond/6919.html'>Sanders County and beyond<span class='mp_author'>Miriah Kardelis</span></a></td></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.scledger.net/story/2021/10/14/obituaries/jacklyn-dean-stephens-foos/6912.html'><img src="/IMG/l_i0IqC7e55Cpkq83zIJ93A96/XPATH/home/cms_data/dfault/photos/stories/id/1/2/6912/s_topXEXT1529x32761is.jpg" width="67" height="50" alt=""></a></td><td class='mp_article' style='width:75%;'><a href='https://www.scledger.net/story/2021/10/14/obituaries/jacklyn-dean-stephens-foos/6912.html'>Jacklyn Dean Stephens...<span class='mp_author'></span></a></td></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.scledger.net/story/2021/10/14/news/two-vie-for-plains-mayor/6898.html'><img src="/IMG/Ssy8E8Mi2HqJhe4IooP-E5vw-/XPATH/home/cms_data/dfault/photos/stories/id/9/8/6898/s_topXEXT1553x32933is.jpg" width="67" height="50" alt=""></a></td><td class='mp_article' style='width:75%;'><a href='https://www.scledger.net/story/2021/10/14/news/two-vie-for-plains-mayor/6898.html'>Two vie for Plains mayor<span class='mp_author'>Ed Moreth</span></a></td></tr>
</table></div><div class="side_separator ss_invisible"></div><!-- Hard Coded Ad --><!-- Square [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc310067 = window.plc310067 || 0;
document.write('<'+'div id="placement_310067_'+plc310067+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(171437, 310067, [150,150], 'placement_310067_'+opt.place, opt); }, opt: { place: plc310067++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script><div class="side_separator"></div><div class="ll_revcontent_ad"><div id="rc-widget-fa853a" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="234702"></div><script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script></div><div class="side_separator"></div><div class="sticky_ad_square"><img src="/IMG/xkPhad7gLXcRahUDqrYCd7qLfyqEDhrwx/XPATH/home/cms_data/dfault/web_ads/square/1394-ledger_canvas.jpgXEXT1212x34260is.jpeg" width="300" height="269" alt="Sanders County Ledger canvas prints"></div><div class="side_separator"></div><!--END SIDEBAR CONTENT AREA-->
     </div>
     <!--END SIDEBAR CONTENT AREA-->
    </div>
   </div>
   </div>




   <div class="bottom_banner_ad widen_vertical_width skel"><!--//////////////////// START READER COMMENTS ////////////////////-->
<a id='readercomments'></a><div class='comments'><h2>Reader Comments<span class="comment-top-text-left">(0)</span></h2><div class="comment-top-text-right align_right">
		<a href='https://www.scledger.net/login?r=%2Fstory%2F2021%2F10%2F14%2Fcommunities%2Fimagination%2Don%2Ddisplay%2F6899%2Ehtml'><img src='/cms/images/comment_icon.gif' alt='comment'> Log in to add your comment</a></div><div class="clear">&nbsp;</div><!--/// CLEAR ///--><div class="clear">&nbsp;</div><!--/// CLEAR ///--></div>

<script src='/apps/clear/clear.js'></script>
<script>
window.addEventListener('load', function () {
  var a;
  a=$($('.right_border')[0]).height();
  CLEAR.f.runOverlay('/ajax/storyheight?id=6899&storyheight='+a);
})
</script><!--Story_full--></div>



   <div class="outer_footer outer">
   <div class="footer widen_vertical_padding inner skel">

      <div class="footer_column_1">
        <h3>Sections</h3>
        <ul><li><a href='https://www.scledger.net/section/news'>News</a></li><li><a href='https://www.scledger.net/section/sports'>Sports</a></li><li><a href='https://www.scledger.net/section/communities'>Communities</a></li><li><a href='https://www.scledger.net/section/opinion'>Opinion</a></li><li><a href='https://www.scledger.net/section/obituaries'>Obituaries</a></li>
        </ul>
      </div>


      <div class="footer_column_2">
        <h3>Newspaper</h3>
        <ul>
          <li><a href="https://www.scledger.net/contact" >Contact</a></li><li><a href="https://www.scledger.net/subscribe" >Subscribe</a></li><li><a href="https://www.scledger.net/about" >About</a></li><li><a href="https://www.scledger.net/photos" >Photos</a></li>
        </ul>
      </div>


      <div class="footer_column_3">
        <h3>Website</h3>
        <ul>
          <li><a href="https://www.scledger.net/terms" >Terms of Use</a></li><li><a href="https://www.scledger.net/privacy" >Privacy Policy</a></li><li><a href="https://www.scledger.net/sitemap_index.xml"  target="_blank">Sitemap</a></li><li><a href="https://www.scledger.net/story/2021/10/14/communities/imagination-on-display/6899.html?m=true" >Mobile Browser</a></li>
        </ul>
      </div>

      <div class="footer_column_4">
        <h3>Advertise</h3>
        <ul>
          <li><a href="https://www.scledger.net/advertise" >Advertise</a></li><li><a href="https://www.scledger.net/directory" >Business Directory</a></li><li><a href="https://www.scledger.net/advertise/placead" >Place a Classified Ad</a></li>
        </ul>
      </div>

      <div class="footer_column_5">
        <h3>Contribute</h3>
        <ul>
          <li><a href="https://www.scledger.net/contact" >Submit Content</a></li><li><a href="https://www.scledger.net/contact" >Letter to the Editor</a></li>
        </ul>
      </div>

      <div class="footer_column_6">
        <h3>Connect With Us</h3>
          <a  href="https://www.facebook.com/sanderscountyledger"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/facebook.png'  height='30' alt=''></a><a  href="https://www.scledger.net/rss"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/rss.png'  height='30' alt=''></a>
        <h4>Sanders County Ledger</h4>
        <p>
          P.O. Box 219 / 603 Main St.<br />Thompson Falls, MT 59873<br />Ph: (406) 827-3421<br /><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="4421202d302b360437272821202321366a2a2130">[email&#160;protected]</a><br />
       </p>
        <p>
          &copy; 2021 Wooden Enterprises, Inc.<br />
       </p>
      </div>


   </div>
   </div>

 <div class="outer_footer2 outer">
   <div class="footer2 widen_vertical_width inner skel">


    <div class="roar_pub">
     <p>Powered by <strong><a href="http://www.lionslight.com" target="_blank">ROAR Online Publication Software</a></strong> from Lions Light Corporation<br />
     © Copyright 2021</p>
    </div>


   </div>
 </div>


  </div>
  

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>

$('.slickcarousel_white').slick({
  dots: false,
  infinite: true,
  speed: 300,
  slidesToShow: 5,
  slidesToScroll: 1
});

$('.slickcarousel_pubfamily').slick({
  dots: false,
  infinite: true,
  speed: 300,
  slidesToShow: 1,
  slidesToScroll: 1
});



$(".more_stories_toggle").click(function () {
    this.style.margin = "0";
    $more_stories_toggle = $(this);
    $more_stories_list = $more_stories_toggle.next(); 							  //getting the next element

//    $more_stories_list.slideToggle("slow", function () {						  //open up the content needed - toggle the slide- if visible, slide up, if not slidedown.

        $more_stories_toggle.text(function () {								  //execute this after slideToggle is done; change text of header based on visibility of content div

            return $more_stories_list.is(":visible") ? "+ More Stories" : "- More Stories";               //change text based on condition
        });
//    });
});




</script>



<script>

//$(".more_stories_toggle").click(function () {
//
//    $more_stories_toggle = $(this);
//
//    //getting the next element
//    $more_stories_list = $more_stories_toggle.next();
//
//    //open up the content needed - toggle the slide- if visible, slide up, if not slidedown.
//    $more_stories_list.slideToggle(200, function () {
//
//        //execute this after slideToggle is done
//        //change text of header based on visibility of content div
//        $more_stories_toggle.text(function () {
//
//            //change text based on condition
//            return $more_stories_list.is(":visible") ? "- More Stories" : "+ More Stories";
//        });
//    });
//
//});

</script>

<script>

$( ".print_sub_container" ).click(function() {
  $( ".print_sub_content" ).slideToggle( 500, function() {
    // Animation complete.
  });
});

</script>

 <small style="padding-top:10px;display:block;">Rendered 10/15/2021 21:12</small><!-- (DESKTOP|PAYWALLTRUE|FULL) (desktop|paywalltrue|full) Cached by Usernum:004399 -->
 <script type="text/javascript">(function(){window['__CF$cv$params']={r:'69ee8f0cad0557ac',m:'7Kxl7rPMxaxg2SKpnv7ZKTquHVUwhuPBRUNqft_qVo0-1634358699-0-ATUGvepUkVqZHHF9c6CTCEDSWt1BcJeT4eAOg0p8x66khjkIs5nZsAQro89R+GSsdhCsKIu4afxjlGfLmjFHT3A7UkG14RDnsG0Z2ZjkXs/spCDNxDcB/ytTUPODGxFLYW/IZUkLQfR73CB9RLulgHjmoEa7pMn3Neb42pTdr4yBY8ffttxQhsCdCOqzbAjGGQ==',s:[0x8e86d37072,0xea4b333673],u:'/cdn-cgi/challenge-platform/h/b'}})();</script></body>

</html>